Docker very slow or failing to load on Windows executors
Incident Report for CircleCI
Resolved
This incident has been resolved.
Posted Jun 24, 2021 - 00:48 UTC
Update
We have identified a potential workaround for those jobs where Docker is failing to load on Windows executors:

Amend the `config.yml` to start the Docker daemon as part of jobs by calling on the `dockerd.exe` binary before running any Docker based steps in the job.

In the mean time we are continuing to monitor the GCP outage and will update accordingly.
Posted Jun 23, 2021 - 10:54 UTC
Update
We are continuing to monitor for any further issues.
Posted Jun 23, 2021 - 10:13 UTC
Monitoring
As recommended by Google, we made changes to use standard instead of SSD storage to work around GCP's outstanding Google Compute Engine outage:

https://status.cloud.google.com/incidents/YtfZu9rttTf5zDYGe57n

These changes have resulted in Docker failing to load or loading very slowly on Windows executors. We plan to revert this change once the GCP outage is resolved. We are not aware of other executors being affected at this time.
Posted Jun 23, 2021 - 10:11 UTC
This incident affected: Windows Jobs.