Pipelines page is degraded, and notifications are delayed
Incident Report for CircleCI
Resolved
We had an incident affecting the CircleCI UI (Pipelines page) and notifications, today (April 22nd) from around 14:45 to around 15:20 [UTC]. This incident has now been resolved.

We have now cancelled affected jobs.
Posted Apr 22, 2020 - 15:45 UTC
Update
We are continuing to monitor for any further issues.
Posted Apr 22, 2020 - 15:23 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 22, 2020 - 15:23 UTC
Investigating
We are currently investigating this issue.
Posted Apr 22, 2020 - 15:18 UTC
This incident affected: CircleCI UI.