Email Notifications Delayed

Incident Report for CircleCI

Resolved

The issue affecting email notifications has been resolved. Build completion emails and plan-related notifications are now being delivered normally. We apologize for any inconvenience this may have caused.
Posted Feb 02, 2026 - 22:18 UTC

Update

We are continuing to monitor for any further issues.
Posted Feb 02, 2026 - 22:05 UTC

Monitoring

Our upstream provider has resolved the issue affecting their system. We are currently monitoring email notification delivery to confirm full restoration. Build completion emails and plan-related notifications should begin flowing normally. All other notification types and build results through the CircleCI web interface and GitHub checks continue to function normally.

We will provide a final update within 15 minutes.
Posted Feb 02, 2026 - 22:05 UTC

Update

We are continuing to work with our upstream provider to restore email notification delivery. Build completion emails and plan-related notifications remain impacted. All other notification types and build results through the CircleCI web interface and GitHub checks continue to function normally.

We will provide an update within 30 minutes.
Posted Feb 02, 2026 - 21:48 UTC

Update

We continue to work with our vendor on restoring email notification delivery. Build completion emails and plan-related notifications remain impacted. All other notification types and build results through the CircleCI web interface and GitHub checks continue to function normally.

We will provide an update within 30 minutes.
Posted Feb 02, 2026 - 21:12 UTC

Identified

We have identified the issue affecting email notifications. Our notification delivery system is experiencing disruptions that are preventing build completion emails and plan-related notifications from being sent. We are actively working with our vendor to restore service. All other notification types, including Slack and webhook notifications, continue to function normally, and build results remain accessible through the CircleCI web interface and GitHub checks.

We will provide an update within 30 minutes.
Posted Feb 02, 2026 - 20:34 UTC

Investigating

We are currently experiencing issues with email notifications across CircleCI. Build completion emails and plan-related notifications are not being delivered as expected. All other notification types, including Slack and webhook notifications, continue to function normally. Build results remain accessible through the CircleCI web interface and GitHub checks.

We are actively investigating the issue with our notification delivery system and will provide an update within 30 minutes.
Posted Feb 02, 2026 - 20:07 UTC
This incident affected: Notifications & Status Updates.