Some customers are experiencing increased Server Errors in the CircleCI UI

Incident Report for CircleCI

Resolved

This incident has been resolved.
Posted Jul 18, 2025 - 20:03 UTC

Monitoring

We identified the cause of the errors and successfully applied a revert. We will continue to monitor the results.
Posted Jul 18, 2025 - 19:37 UTC

Investigating

Some customers may be unable to view pages in the CircleCI UI due to "500 Error: Server Error". We are currently investigating the issue.
Posted Jul 18, 2025 - 19:32 UTC
This incident affected: CircleCI UI.