Job links/pages may return information for the wrong job
Incident Report for CircleCI
Resolved
We have continued to monitor this issue and we have seen no new occurrences. We are marking this incident as resolved, however if you have existing jobs having this problem that occurred between 2020-07-07 17:30 UTC to 2020-07-09 14:25 UTC that you need corrected, please submit a support request (https://support.circleci.com/hc/en-us/requests/new) with a link to the affected job. We will then be able to fix it so it directs properly.
Posted Jul 09, 2020 - 19:12 UTC
Update
As an update, we are still investigating what options are available for addressing the existing jobs that are redirecting within a project. We will post a further update once we have additional details.
Posted Jul 09, 2020 - 16:43 UTC
Update
Our fix for future jobs is deployed and stable. We are currently working on a solution for existing, historical jobs that are still redirecting to previous run jobs in the same project.
Posted Jul 09, 2020 - 15:19 UTC
Monitoring
We have implemented a fix for this issue and future jobs will no longer encounter the problem. However, any existing jobs will continue to direct to previously run jobs in the project. We are investigating options to correct the existing jobs.
Posted Jul 09, 2020 - 14:25 UTC
Update
To clarify the scope, the job link will only point to another job within the same project. Specifically, a previously run job in another pipeline within the project.
Posted Jul 09, 2020 - 13:58 UTC
Identified
We have identified an issue where some job links may point to the wrong job. For instance, when clicking a job on the workflow page the wrong job may open up. This impact may include jobs which were created within the past 24 hours. We are working on a resolution at this time.
Posted Jul 09, 2020 - 13:43 UTC
This incident affected: Pipelines & Workflows and CircleCI UI.