Increased wait times for macOS jobs

Incident Report for CircleCI

Resolved

Wait times for macOS jobs are back to normal.
Posted Sep 14, 2026 - 12:59 UTC

Monitoring

Our macOS hosting provider has implemented a mitigation and we have seen improved latencies. We will continue to monitor.
Posted Sep 14, 2026 - 12:48 UTC

Update

Wait times for macOS jobs are reducing and we are continuing to investigate.
Posted Sep 14, 2026 - 12:36 UTC

Investigating

Due to increased network errors and latencies we are seeing increased wait times for macOS jobs. We are investigating this with our macOS hosting provider.
Posted Sep 14, 2026 - 11:59 UTC
This incident affected: macOS Jobs.