Pipelines page intermittently not loading pipelines.

Incident Report for CircleCI

Resolved

This incident is now resolved.
Posted Mar 21, 2025 - 12:14 UTC

Monitoring

The pipelines page is recovering and we are observing normal behaviour. We are continuing to monitor.
Posted Mar 21, 2025 - 11:25 UTC

Update

We have identified the cause and are continuing to work on a fix.
Posted Mar 21, 2025 - 10:54 UTC

Identified

We have identified an issue causing a timeout when loading the Pipelines page on projects. We are currently working on a potential fix. Pipelines are running as normal.
Posted Mar 21, 2025 - 10:32 UTC
This incident affected: CircleCI UI.