Customers may see delays with status updates on Github

Incident Report for CircleCI

Resolved

The issue impacting status updates for Github App basic status has now been resolved. Please note that a small percentage of pipelines triggered directly from the CircleCI API did not post status to Github and must be re-run. If you have any further issues, please reach out to support for assistance.
We thank you for your patience and understanding as our engineers worked towards mitigation.
Posted Mar 31, 2025 - 17:02 UTC

Update

We are continuing to monitor for any further issues.
Posted Mar 31, 2025 - 16:50 UTC

Monitoring

A small percentage of pipelines triggered directly from the CircleCI API did not successfully post status to GitHub. To post status, the pipeline must be re-run.
Posted Mar 31, 2025 - 16:50 UTC

Investigating

Our engineers are investigating an issue where some customers may see delays with status updates. The impact is limited to Github App basic status and does not affect oAuth basic or Github checks.
We appreciate your patience and understanding as we actively work to resolve this delay. We will keep you updated on our progress.
Posted Mar 31, 2025 - 16:31 UTC
This incident affected: Notifications & Status Updates.