circleci/aws-eks Orb is Causing Build Failures
Incident Report for CircleCI
Resolved
We have released a fix for our circleci/aws-eks orb. If you are experiencing this behavior you will have to update your orb version to v2.1.2
Posted Apr 09, 2022 - 18:37 UTC
Update
We have identified a possible fix on our end and will begin testing
Posted Apr 09, 2022 - 17:32 UTC
Identified
This issue was caused by the release of the Kubernetes AWS-IAM-Authenticator that the circleci/aws-eks orb utilizes. The current workaround is to set the authenticator-release version tag to a previous, working version. More information can be found here: https://github.com/kubernetes-sigs/aws-iam-authenticator/issues/449#:~:text=as%20a%20fallback%2C%20it%20seems%20that%20the%20orb%20has%20this%20property%20authenticator%2Drelease%2Dtag%2C%20that%20you%20can%20use%20to%20set%20the%20previous%20release%20version%20of%20this%20lib
Posted Apr 09, 2022 - 16:42 UTC
Investigating
We are seeing build failures from workflows that use the circleci/aws-eks orb
Posted Apr 09, 2022 - 16:32 UTC
This incident affected: CircleCI Dependencies (AWS) and Pipelines & Workflows.