GitHub Webhooks and API degraded
Incident Report for CircleCI
Resolved
Delays in jobs triggering and GitHub checks have been resolved, we are continuing to monitor but customer impact has been resolved.
Posted Feb 27, 2020 - 16:25 UTC
Update
GitHub services are returning to normal, and time to trigger jobs or workflows are returning to normal. Delays for GitHub Checks should also be returning to normal.
Posted Feb 27, 2020 - 16:10 UTC
Update
We are monitoring of the GitHub API and webhook deliveries. Workflow and job triggering is delayed, along with other GitHub API reliant actions.
Posted Feb 27, 2020 - 15:35 UTC
Update
Workflows and jobs continue to be delayed, along with GitHub Checks and other interactions with the GitHub API.
Posted Feb 27, 2020 - 15:14 UTC
Update
We are continuing to monitor the status of the GitHub API and webhook deliveries.
Posted Feb 27, 2020 - 14:46 UTC
Monitoring
Workflow and job triggering is delayed, GitHub Checks are queued.
Posted Feb 27, 2020 - 14:23 UTC
This incident affected: Upstream Services (GitHub API Requests).