Final results of some jobs may not be reported in the UI

Incident Report for CircleCI

Resolved

All jobs are now running normally. Thank you for your patience whilst we resolved the issue.
Posted May 02, 2025 - 00:45 UTC

Update

We are continuing to monitor for any further issues.
Posted May 02, 2025 - 00:36 UTC

Update

Jobs for the following resource classes will have suffered significant delays in running, these will be processed over the next X minutes.

* Docker Large, Medium and Small
* Linux Large

Those jobs will start within the next 15 minutes, you should not need to retry them. We thank you for your patience whilst we resolve this issue.
Posted May 02, 2025 - 00:29 UTC

Update

We're continuing to monitor the delays with starting Docker jobs. Thank you for your patience.
Posted May 01, 2025 - 23:43 UTC

Update

Docker jobs have not recovered as expected, and customers may continue to see delays for Docker jobs starting. We are working to increase capacity and thank you for your patience.
Posted May 01, 2025 - 23:05 UTC

Update

This incident impacted final result delivery between 22:06 and 22:17 UTC. Customers may experience delays starting Docker Large jobs as the system recovers. We will continue to monitor recovery and thank you for your patience.
Posted May 01, 2025 - 22:49 UTC

Monitoring

This also impacts status checks which may not have been sent to GitHub.
Posted May 01, 2025 - 22:40 UTC
This incident affected: Docker Jobs, Machine Jobs, macOS Jobs, and Windows Jobs.