Issues loading the jobs page

Incident Report for CircleCI

Resolved

This incident has been resolved.
Posted Feb 20, 2025 - 20:02 UTC

Monitoring

The jobs page has automatically recovered. We have identified the change that caused this issue and have reverted it so that the issue cannot reoccur. Thank you for your patience.
Posted Feb 20, 2025 - 19:53 UTC

Investigating

Our engineering team is currently investigating an issue affecting some customers with loading the jobs page. Please note that jobs continue to flow through the system without interruption; the impact is limited to the user interface only.
We will provide updates as soon as more information is available. Thank you for your understanding!
Posted Feb 20, 2025 - 19:33 UTC
This incident affected: CircleCI UI.