Machine builds fail with "Infrastructure Fail" error
Incident Report for CircleCI
Resolved
This incident has been resolved.
Posted Nov 25, 2021 - 15:18 UTC
Monitoring
A fix has been implemented and we can confirm that we're not seeing any new occurrences of the errors.

In case your builds were affected and if you haven't modified the image(s) you were initially using, you can now rerun the builds.
Posted Nov 25, 2021 - 15:04 UTC
Identified
We have identified the cause of the issue, and we're currently working at implementing a fix.
Posted Nov 25, 2021 - 14:55 UTC
Investigating
We are investigating an issue causing infrastructure failures for a small portion of our customers who are using Linux images.

The issue appears to only occur for jobs using `machine: true` or older images.

As a workaround, we suggest specifying a recent machine image. You can find a list of available machine images here: https://circleci.com/docs/2.0/configuration-reference/#available-machine-images
Posted Nov 25, 2021 - 14:37 UTC
This incident affected: Machine Jobs and Pipelines & Workflows.