Degradation in CircleCI UI elements

Incident Report for CircleCI

Postmortem

What happened
All modals and dialogs across the CircleCI application became invisible. They were being rendered correctly in the background, but were not visible to users. This affected approval jobs, SSH key management, and other settings pages across the app.

Root cause
The issue was introduced by an upgrade to our internal design system library. The new version added animation support to modal components using a library called Framer Motion. These animations are designed to fade modals in from invisible (opacity: 0) to visible (opacity: 1) when opened.

However, the animation logic reads open/close state from a specific React context that is only available when modals are opened via a particular component (DialogTrigger). Our application manages modal state differently, passing open/close state directly via props, so that context was never populated. As a result, every modal in the app was permanently stuck in the "hidden" animation state and never transitioned to visible.

Resolution
We reverted the design system upgrade to restore the previous working version, which resolved the issue immediately. We are now working on a follow-up fix that will upgrade Framer Motion properly, by ensuring all modal components receive the required context.

Impact
The issue affected all modal dialogs across project settings, org settings, user settings, plans & payments, and other areas of the app for the duration of the incident. No data was lost or corrupted. The underlying functionality was intact, just inaccessible via the UI.

Posted Apr 07, 2026 - 00:22 UTC

Resolved

This incident has been resolved.
Posted Apr 06, 2026 - 21:12 UTC

Monitoring

A fix has been implemented and we are monitoring the results. Thank you for your patience.
Posted Apr 06, 2026 - 20:43 UTC

Investigating

We are currently investigating an issue in the CircleCI UI impacting approval jobs and SSH key navigation. This is an interface-only issue and builds continue to flow as usual.
Posted Apr 06, 2026 - 20:33 UTC
This incident affected: CircleCI UI.