Windows, Android and GPU jobs experiencing increased queueing

Incident Report for CircleCI

Resolved

We have resolved this issue and wait times for jobs should now be normal. Thank you for your patience while we worked on this issue.
Posted Jul 10, 2025 - 09:58 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 10, 2025 - 09:36 UTC

Identified

We're experiencing capacity issues with our compute provider. Customers may experience increased queue times for Windows, Android and GPU jobs. We're currently working to resolve this issue and appreciate your patience.
Posted Jul 10, 2025 - 09:01 UTC
This incident affected: Machine Jobs and Windows Jobs.